aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNathan Reiner <nathan@nathanreiner.xyz>2024-09-17 00:32:17 +0200
committerNathan Reiner <nathan@nathanreiner.xyz>2024-09-17 00:32:17 +0200
commit5756b833718d8b7bc8db378dd9dbebc52aa61220 (patch)
tree3d7fdbcaeb5c7a7bf9df7f1ab6e7fd8a0d4c265a /flake.nix
parent29fd67f47171f9a176eb6f7e0ecee3cc9f91c99a (diff)
options.url: allow port specification
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix2
1 files changed, 1 insertions, 1 deletions
diff --git a/flake.nix b/flake.nix
index 765c544..f7f3986 100644
--- a/flake.nix
+++ b/flake.nix
@@ -41,7 +41,7 @@
options = {
url = lib.mkOption {
description = "URL of the WebTray instance";
- type = lib.types.strMatching "https?://[a-z0-9.]*";
+ type = lib.types.strMatching "http[s]?://[a-z0-9.]*:?[0-9]*";
};
autoStart = lib.mkOption {
description = "WebTray Instances to start on login";