aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
authorNathan Reiner <nathan@nathanreiner.xyz>2024-09-21 12:55:37 +0200
committerNathan Reiner <nathan@nathanreiner.xyz>2024-09-21 12:55:37 +0200
commit21afec7d459855808444ef8157a2249b2fb2782c (patch)
tree837a9914bc75314ab6946f8b1a2a9f87c19cb0dc /flake.nix
parent121297159b40b9cd8d5016893e83e9f01d0795ec (diff)
resolve quit segfault
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 10 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 21b5f58..a935eac 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,14 +14,18 @@
packages.x86_64-linux.default = pkgs.stdenv.mkDerivation {
name = "webtray";
src = self;
- buildPhase = "qmake6 . && make";
+ buildPhase = "qmake . -- -webengine-webrtc-pipewire && make";
installPhase = "mkdir -p $out/bin; install -t $out/bin webtray";
- buildInputs = [
- pkgs.kdePackages.wrapQtAppsHook
- pkgs.kdePackages.qmake
- pkgs.kdePackages.qtwebengine
- pkgs.kdePackages.qtwayland
+ nativeBuildInputs = with pkgs; [
+ qt6.wrapQtAppsHook
+ makeWrapper
+ ];
+
+ buildInputs = with pkgs; [
+ qt6.qmake
+ qt6.full
+ qt6.qtbase
];
};