aboutsummaryrefslogtreecommitdiff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix16
1 files changed, 10 insertions, 6 deletions
diff --git a/flake.nix b/flake.nix
index 21b5f58..a935eac 100644
--- a/flake.nix
+++ b/flake.nix
@@ -14,14 +14,18 @@
packages.x86_64-linux.default = pkgs.stdenv.mkDerivation {
name = "webtray";
src = self;
- buildPhase = "qmake6 . && make";
+ buildPhase = "qmake . -- -webengine-webrtc-pipewire && make";
installPhase = "mkdir -p $out/bin; install -t $out/bin webtray";
- buildInputs = [
- pkgs.kdePackages.wrapQtAppsHook
- pkgs.kdePackages.qmake
- pkgs.kdePackages.qtwebengine
- pkgs.kdePackages.qtwayland
+ nativeBuildInputs = with pkgs; [
+ qt6.wrapQtAppsHook
+ makeWrapper
+ ];
+
+ buildInputs = with pkgs; [
+ qt6.qmake
+ qt6.full
+ qt6.qtbase
];
};